### XSI Hot Key Reference

<table>
<thead>
<tr>
<th><strong>General Keys</strong></th>
<th><strong>Editing and Selection Keys</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>x</td>
</tr>
<tr>
<td>2</td>
<td>c</td>
</tr>
<tr>
<td>3</td>
<td>v</td>
</tr>
<tr>
<td>4</td>
<td>t</td>
</tr>
<tr>
<td>Ctrl + 2</td>
<td>M</td>
</tr>
<tr>
<td>Ctrl + 3</td>
<td>R</td>
</tr>
<tr>
<td>Ctrl + 4</td>
<td>E</td>
</tr>
<tr>
<td>Ctrl + Shift + z</td>
<td>D</td>
</tr>
<tr>
<td>6</td>
<td>Ctrl + d</td>
</tr>
<tr>
<td>Ctrl + o</td>
<td>Ctrl + z</td>
</tr>
<tr>
<td>Ctrl + s</td>
<td>Ctrl + y</td>
</tr>
<tr>
<td>5</td>
<td>Ctrl + d</td>
</tr>
<tr>
<td>Alt + 5</td>
<td>Ctrl + d</td>
</tr>
<tr>
<td>Ctrl + 6</td>
<td>Ctrl + d</td>
</tr>
<tr>
<td>8</td>
<td>Ctrl + d</td>
</tr>
<tr>
<td>9</td>
<td>Ctrl + d</td>
</tr>
<tr>
<td>0</td>
<td>Ctrl + d</td>
</tr>
<tr>
<td>Alt + 7</td>
<td>Ctrl + d</td>
</tr>
<tr>
<td>Ctrl + 8</td>
<td>Ctrl + d</td>
</tr>
<tr>
<td>Ctrl + 0</td>
<td>Ctrl + d</td>
</tr>
<tr>
<td>a</td>
<td>Ctrl + d</td>
</tr>
<tr>
<td>f</td>
<td>Ctrl + d</td>
</tr>
<tr>
<td>h</td>
<td>Ctrl + d</td>
</tr>
<tr>
<td>Shift + h</td>
<td>Ctrl + d</td>
</tr>
<tr>
<td>Ctrl + h</td>
<td>Ctrl + d</td>
</tr>
<tr>
<td>Shift + SpaceBar</td>
<td>Ctrl + d</td>
</tr>
<tr>
<td>r</td>
<td>Ctrl + d</td>
</tr>
<tr>
<td>q</td>
<td>Ctrl + d</td>
</tr>
<tr>
<td>enter</td>
<td>Ctrl + d</td>
</tr>
<tr>
<td>Alt + enter</td>
<td>Ctrl + d</td>
</tr>
</tbody>
</table>

© Interactive Systems and Virtual Reality Research Group – Macquarie University, 2006
Chapter I. XSI User Interface

Introduction
Welcome to this brief introduction to Softimage\XSI. This introduction is written based on 4.0 and by the time of making this document, Avid has just released XSI 5.0. A lot of improvements have been implemented from XSI 4.0 to 5.0, but the interface should be similar.

This Introduction to XSI will help you understand and work with XSI. Also, it will show you how to customize your work environment for productivity. The intended audience for this document are those who are new to XSI. If you're after more in-depth topics in modeling, rendering, animation, texturing, lighting and compositing, please refer to Recommended Reading section in Chapter III.

XSI is the next generation in digital animation software. It was used to create animations in movies such as Jurassic Park series, Terminator 3, A.I, etc, and also used to develop games such as; Resident Evil by Capcom, Metal Gear Solid 4 by Konami and many more. What makes it a powerful package is its non-linear architecture, the friendly user interface as well as its comprehensive tools for modeling, texturing, all the way to compositing.

At the end of the tutorial, you'll be able to work your own way through XSI user interface, work effectively in a production environment as well as doing simple tasks within Softimage. Wherever you want to take your XSI skill further in either Games, Broadcasting or Film industry is entirely up to you and we wish you all the best.

NOTE:
Under Select menu on the Main Command Panel (Right Toolbar) make sure these options are enabled:

- Select Single Object in Region
- Softimage\3D Selection Model
- Extended Component Selections

For consistency in this document these three options should be toggled on at all times. As you become more proficient with Softimage you're likely to use these settings.
XSI User Interface

The Top menu bar has all the menu options and features XSI offers. The File Menu contains all commands required to open, save, export, import, user preference and keyboard mapping.

Project Manager helps to manage scenes in different project and assist in sharing scenes amongst people working in a the team.

Under View menu you can have XSI to display certain components in a scene at various viewports. For instance, toggling View->Polygon Normals on will display the normals of a selected object on all viewports, whereas toggling Show->Polygon Normals from one viewport will display normals on that viewport only.

Under Application->layout you can customize XSI interface as you prefer.

XSI documentations could be found under Help menu, provided that they were installed along with XSI.
The Four modules in XSI
The default Toolbar on the left of the screen contains 4 modules of XSI; Model, Animate, Render and Simulate. The default module is Model. You can switch from one module to another by using hotkeys (1, 2, 3 or 4) or simply left click on the module name and choose which module you'd like to activate.

Model
This is where you start to work, where you will construct all the elements in your scene. Model's tools allows you to create objects from primitive shapes, curves, by extrusion, creating surfaces, etc. In this module you are able to create light, apply shader, and creating a texture projection. This Module contains the tools to create and edit an object including boolean operations, merging, 3D text, etc.

Animate
Contains the tools to add animations in your scene. This module contains special tools for attaching object to a path, setting up Inverse Kinematics, deformations, enveloping and weighting skin to skeleton. In this module you can store, load and save animations for use with non-Linear Animation Mixer.

Render
Contains the tools to add and manipulate shader and texture for your objects, also tools to set up render passes and partitions. This module has the settings for render region as well.

Simulate
Contains the tools to create cool dynamics effects such as; fluid simulation, cloth, or hair by using simulated physical forces. You can create a particle emitter to make rain, meteor rain or even dragon's flaming-breath. You can also set up collision for objects in your scene. The only limitation of what you can do is your imagination.

Division within Modules
Modules are further divided into sections according to the functions of the tools. Inside the Model module, the tools are divided further into Get, Create and Modify.
Under Get, you can bring in pre-made object in your scene. From Create, you may create object from scratch. Under Modify section, you have tools to modify our object.

The Animate module is divided into Get, Create, Deform, Actions, Tools.
The Render module is divided into Get, Modify, Render and Pass.
The Simulate module is divided into Get, Create, Modify and Tools.
This division, actually, makes tasks even simpler. For instance, if we want to create a curve by sketching, would correspond to Create->Curve->Sketch. Or say for example, we want to modify the existing curve by closing it, which would correspond to Modify->Curve->Open/Close.

At the bottom of left toolbar, there are 4 buttons. The first button is usually toggled on by default. This lets us to switch around between 4 modules in XSI.

The one that looks like scissors will enable the Hair Toolbar. With this toolbar you'll get the options to create and modify hair for your character.

The one that looks like a brush is the Weight Panel Toolbar. This provides tools to edit weights of your character by painting the deformer's influence over the skin envelope.

The one that looks like a sea shell is the Palettes and Display Types Toolbar. You can change the way the objects displayed on the screen by using this toolbar. This will be very handy when your scene becomes complex. Changing the color of the way object displayed on the screen will not change the render result. For this to take effect in the viewport, make sure that “Override Object Properties” option is enabled in your viewport.
Main Command Panel (MCP)
Whenever you see a small triangle that means that's a drop menu.
The menu on the right of the screen is called Main Command Panel. This
MCP contains all the menus that you're likely to use while working in
XSI.
In MCP there are menus to control layers in your scene, sub-component
selections, SRT (Scale, Rotation and Translation), snapping options,
constrains options, parenting, cluster and grouping options.
You can enable proportional modeling from MCP. Proportional
modeling turns your model like a rubbery object while modeling; you
may stretch and mold your object easily.

From MCP you can specify if you'd like to do transform on Object's
Local axes, Global axes or based on the View.

You can also search for an object in the MCP. If you have an object
named 'mybox' and 'mytorus', you could select either one by entering the
object name in the search field, then press enter. You may use wildcards
as well, for example if you search for 'my*' and press enter, XSI would
select 'mybox' and 'mytorus'.

Timeline
The Timeline is located at the bottom of the screen. It shows you the
duration of your animation in your scene. Timeline contains menus to
keyframe for animation, jumping from one keyframe to another and to
play back/forth the animation.

Feedback line
Feedback line is located at the bottom of Timeline.
When you're learning XSI or any other software packages, ALWAYS
pay attention to the feedback line. It provides additional information
about the tool you're using.

For an example, if you do Create->Curve->Draw Cubic by Cvs, the
status line will tell you that LMB (Left Mouse Button) will add points,
MMB (Middle Mouse Button) will add a point in between of 2 other
points, and RMB (Right Mouse Button) will open a context sensitive
menu.

XSI User Interface and Productivity
The default keys that comes with XSI are useful, but as you become more proficient with the XSI
you will find it slow, especially if you're working fast with lots of object in your scene. This small
section will talk about optimizing your user interface to increase your productivity.

XSI Hot Keys
It's a good practice to have one hand on the keyboard and another on the mouse. It's true that the
menus in XSI are arranged so that they can be accessed easily but it takes time to move your cursor
around the screen.

For example, moving and translating an object without keyboard interaction would be like; move cursor to mcp, click object selection button, move cursor, click translation, move cursor translate object, move cursor again to rotate, click rotate on MCP, move cursor again and rotate object. Another example, same scenario with keyboard interaction; hold Spacebar, click on object, hold v, translate object, hold c, rotate object. When you're doing a complex modeling or building a complex scene, you'll fully appreciate the existence of hot keys :)

It is important to memorise all the hot keys, starting from the common hot keys that you're mostly use.

Just in case if you're planing to learn Blender, don't worry about where to find the buttons to do things, just memorise ALL the hot keys. To some users, Blender's user interface is very intimidating and like a maze.

**Selecting Object with Shift and Control**

Hold Spacebar to get into object selection mode. When you need to select more than one object, hold Shift while holding Space bar and click the object. When you need to deselected an object, hold Ctrl while holding Shift and Spacebar and click the object that you want to deselected.

Holding 3 keys could be tricky, as this require a good dexterity. Alternatively you could hold Spacebar and Ctrl to add or deselect object from selection.

You will be able to work faster and precise in XSI if you remember to hold Spacebar whenever you need to select an object.

**Context Sensitive Menus**

In most places, clicking your RMB will bring up a context menu. When you do RMB on the viewport, you'll be given option to modify camera properties, dolly, orbit, pan, walk mode and etc. RMB on an object will give you commands to perform Add polygon, Add Edge, Add points, rename, clone duplicate, etc.

Certain tools have RMB mapped to something else and you have to end it by tapping ESC or RMB before accessing context menu. In NIL tool (under file->Preferences... -> Interaction--Tools), the RMB always pops up context sensitive menu.

If you wish to access a context menu without leaving the tool you're currently in, hold Alt and click RMB

**Stickiness**

When you enter a command on the object selected, XSI will stay in the command until you hit ESC or sometimes RMB.

For instance, after doing a complex scene you might arrange the object into a hierarchies by using Parent Tool. XSI will remain in the Parent Tool command until you hit ESC. With the stickiness toggled on, make habit to press ESC after executing a command. Not all command works like this.

Hotkeys can be sticky too if you have the sticky option enabled under File-> Preferences... ->Interaction-> tools.

Turning on Stickiness can be a bad idea.
When you tap 'o', XSI will stay in orbit mode until you hit ESC. Shift, Ctrl and Spacebar selection methods described above can be slow and confusing when you're working fast with lots of objects in your scene.

**Softimage|3D Selection Model (recommended strongly)**

Softimage|3D selection model accelerates working with selections. For example, tree/branch selection while working with other tools at the same time, for increasing productivity. To use this SI|3D selection model:

- Preferences->Interaction->Tools;
  - turn off Enable Sticky Keys
  - set Default Tool to 'Nil'
- Under Select menu on the Main Command Panel (Right Toolbar) make sure these options are enabled:
  - Select Single Object in Region
  - Softimage|3D Selection Model
  - Extended Component Selections

Now, to select object we hold down Spacebar. When you hold 'u', it works to select, deselect and toggle polygons. Look at the feedback line to see what “Extended Component Selection” offers.

**Viewports and Cameras**

The default user interface has 4 viewports; top, front, right and user (perspective camera) view. You can resize the viewports by dragging the border around. To restore the viewports MMB the intersections of the viewports.

The default key to maximise viewport is F12 which is far from the other tools. It is recommended to set the key to maximise view port as Alt+Spacebar. The reason is that performing Alt + Spacebar is very quick and convenience, it is close to other common keys to navigate, SRT and object selection. Also, usually after maximising a viewport (Alt+Spacebar), you're likely to select an object (Spacebar).

If the scene require many cameras, you may create another one and set each viewport to look inside different cameras. Make sure you name them properly so you know which camera to render. You can tweak the setting from a selected camera in **Viewport toolbar->Camera->Properties**.

The default display setting in every viewport is Wireframe. You can change this by clicking it and choose from the drop menu. From this drop menu you can enable rotoscoping, which is handy if you need to do modeling from a sketch or planning for character animation from a live footage. XSI display system is flexible, you may have different display setting for every viewport.

Every Viewport has 4 memo cam slot, memo cam slots allows you to save camera locations by MMB click on the slot. RMB click to clear the slot.

**Property Pages (PPG)**

Every object in XSI has it's own properties. When you create a new object you will see a general property page of that object, where you can specify things like, name of object, number of V/U subdivision and more (depending on the object). You can also create another property page for your object and add options in it.
There are several ways to inspect the properties of an object.

- Select an Object with Spacebar and hit Enter key (General Property Page)
- Select an Object with Spacebar and hit Alt+Enter (All Properties...)
- Select and object with Spacebar and RMB on the object, properties->...general - all
- Select the object from Explorer or Schematic view, left click once on the icon on the left of object name (or double click on the object name)

You can lock the ppg by clicking the lock button, just in case if you still want to see sphere's ppg while clicking on another object. Otherwise the ppg will be switched to current selected object.

**Explorer**

By default, the explorer shows all objects in your scene, including the construction history performed on the object in a tree-structure format. You can filter out the information displayed by layer, selection, render pass or group.

In explorer you can perform parenting by dragging a child object with MMB and drag it under a parent node object.

XSI Explorer is a new variation of the Explorer. It has 2 panels, the first panel is the list of objects in the scene and the second panel usually blank. You can set the second panel as Schematic view, Object Viewer, Texture Editor, Render Tree or even PPG. Basically, XSI allows you to edit one object at a time without being bothered with all other stuff in your scene.

*Illustration 6: Explorer*
Schematic View

The Schematic view can be used to arrange your scene, making object selections, see relationship between objects and to assign shaders. You can filter out the information schematic view displays on the screen. This schematic view has 4 memo cam slots.

[Image: Schematic View]

Projects, Opening and Saving

XSI has a great project management system to make it easy to manage multiple projects at the same time. Project Manager dialog box is located in File -> Project Manager. Before you can create a new scene, you must create a project (File -> Project Manager -> New Project).

A Project is like a container of all your work in XSI. Each Project is actually a folder systems which contains many sub-folders to organise your work. These folders are; Actions, Audio, Backup, dotXSI, Expressions, Fcurves, Models, Pictures, Queries, Render_Pictures, Scenes, Scripts, Shaders, Simulations and Synoptic.

When you create a new scene, it will be saved under Scene folder. You may have as many scenes in one project. To start a new scene, you may click New Scene button from Project Manager dialog box or File -> New Scene.

To save a scene click on File -> Save or File -> Save As which writes a new scene into your project. You may also save a scene with thumbnail. In order to do this, you need to draw a render region on the screen (Q key), then when you choose File -> Save, check 'Use Render Region As Thumbnail'.
Chapter II. Valley of the Windmills - part 1

Valley of the Windmills – this XSI tutorial will cover basic modeling, organising scene into layers and basic animation.

The Sketch
Here's the list of objects required in the scene;
- 3 x Windmills (We'll make one model and duplicate it twice)
- 5 x Wooden Arches (as above)
- 1 x Terrain
- an extra camera to go through the wooden arches

We'll create the windmill first, then the wooden arches, lastly the terrain. Each will be on a separate layer. When the scene is set up we'll add a path along the arches and attach a camera to the path.

The Windmill
We'll start by renaming the current layer to “Windmill_Layer”. This is the active layer so basically whatever you create while this layer is highlighted will be under this layer. Press 6 to access the Layer Control.

Create a Cylinder from Primitive->Polygon Mesh->Cylinder. Set Radius = 3, Height = 16, U Subdiv = 10, V Subdiv = 3, Base subdiv = 3, and open the bottom end. Name it WindMill_Body.

Naming is very important, as your scene gets complex, you'll be able to find your objects quickly by naming them properly.
Move WindMill_Body object up, so that the bottom touches the ZX plane. Go to front View, Use V key and MMB (Middle Mouse Button) while dragging your mouse to move it up. This could be done easily also by snapping (Holding Ctrl and V while dragging with MMB).

Alternatively, you can also move object up in perspective view, make sure that the transform mode is on Global on MCP (Main Command Panel), and use V key and MMB while dragging your mouse to move it up, use snapping to be precise.

Go to Front viewport, tag all the points at the top by holding T key and LMB (Left Mouse Button), and scale them smaller in X and Z direction, about half the size of the bottom portion of the cylinder (hold X key, drag mouse with holding LMB and RMB).
When you're done, un-tag all the points by holding T key and MMB dragging. Do the same for the other rows of points on the cylinder so that it look something like;

Now we'll shape the top of the cylinder to form like a dome. Select the inner points at the top, move it up slightly.
Select the second inner points, at the top and move it up slightly.

Select the middle top point and move it up slightly. And we have a shape that would look like a dome at the top of the Windmill.
Tap Spacebar to get out from point selection mode to Object selection mode. At this point, your model should look like the following:
**Blade Axle**

Create another Cylinder primitive and use these following settings;
- Radius = 0.3,
- Height = 3,
- U subdiv = 8,
- V and Base subdiv = 1.

Rotate it by 90 degree x-axis, by holding C key and LMB dragging. Use Shift key to do rotation incrementally (15 degree) or enter the value of 90 in X rotation in MCP.

Move it up by 14 units by using v key and MMB dragging (or enter the value of Y transformation in MCP). Position it so that 2/3 on the object sticks out from the windmill body, towards +z axis direction.
The Blades
Go to Front Viewport, create a polygon cube. Primitives->Polygon Mesh->Cube. Name it “Blade_1” and set everything to 1 unit.

While the object still selected, click on Center button on MCP to access the object's center/pivot.

By holding V key and MMB dragging, move the center to the bottom of the cube. When you're done click on Object button on MCP to switch to Object selection mode.
Move the cube up so that the center of the cube sits on the center on the blade axle.

From MCP, set the X scaling to 0.5, set the Y scaling to 10, set the Z scaling to 0.2. You would get the following shape;
Let's shape the blade now. Select the right-topmost points by holding T and rectangle selection with LMB. Move the points like shown below by using holding V key, set the translation mode to View in MCP and use LMB to do translation in front viewport.

Switch to Object mode by tapping Spacebar.
Go to perspective viewport, move the blade towards the edge of the blade axle by using V key and Local/Global transformation mode.
Make sure the blade is already selected, from MCP click on **Edit -> Duplicate/Instantiate -> Clone Multiple.**

With **Cloning**, if we modify the original, the copy/clone would be modified automatically as well. With **Duplicate** there's no relationship between the original model and the copy.

Set number of copies to 2. Under “Duplicate Options - Transform” set the rotation in Z to 120. Click OK.

You would get 2 more blades and they are at 120 degree apart from another.
Select all the Blades, click **Parent** Button on MCP (under Constraint), MMB click on the blade axle, and RMB to end Parent Tool.

Now the blade axle is the parent of the blades, if you rotate the blade axle on it's **Y Local axis** or on it's **Z Global axis**, the blades would turn as well. Open up the schematic view by using 9 key and you can see the blades are the children of the blade axle.

Now, make the Windmill body to be the parent of the blade axle.

The final step would be to make this Windmill into a Model. Creating Model Menu can be accessed from Model Toolbar -> **Model -> New Model**.

**Model** in XSI is a Container for objects/models in the scene. A Model can be stored internally within scene or externally if you're working in collaboration with others. Once you create a Model for your objects in the scene you can Instance them instead of Cloning/Duplicate.

With **Instancing**, it doesn't create objects. You can't modify the Instanced Models. The Instanced model will be modified according to modification performed on the original Models.
With **Clone** and **Duplicate**, objects will be created, and you can modify the cloned/copied objects.

Select all the the objects, on MCP click **Freeze M** button. **Freeze M** freezes the modeling of the selected object, it removes the operators in the Modeling region of the geometry operator stack. In short, it removes the construction history.
With all Object still selected, click **Model->New Model**, name it “**WindMill_Model_1**” and use “**Internal**” option. Click OK. You can see the newly created model from Explorer. Explorer can be accessed by tapping 8 key.

It's very important to freeze your objects in the scene before doing animations, otherwise the object won't animate properly. Freezing is also important when you're doing a complex modeling and the software starts to slow down. By freezing you'll be able to free up more resources for the software to use.

**Spinning the Blade Axle of a Windmill**

Let's Animate!!! Press 2 to bring up the **Animate Toolbar**. Before we start, set the maximum frame to 300 (right bottom screen), because we'll be doing 10 seconds animation. We'll animate the blade axle by key frames and later on we'll create a “Clip” which can be used in animation mixer.

Make sure that the marker is at 1 and select the blade axle only.
Make the Z global rotation to 0 (if it's not already 0). Hold C key, click on the **Key** Icon on the Timeline toolbar to add a keyframe.

The Key icon will be highlighted Red, which means at that frame there is a Key.

Scrub the marker to frame 300, set the Z global rotation to 900 (by entering 900 on Z transform field). Hold C key and click the Key Icon on the Tool bar again.

So what have we done here?
At frame = 1  ...we set...  Y local rot  =  0
At frame = 300  ...we set...  Y local rot  = 900

Basically in 10 seconds the blades will rotate 900 degree.

Click play or scrub the marker on the timeline to see how the blades rotate between frame 1 – 300.

We will now convert this animation as a Fcurve (Function Curve). With the blade axle still selected, hold C key, click **Store-> (release C key)** **Mark Parameters – Fcurve**. Name the action “**Spinning_Axle**”. Click OK.
If you click play or scrub the marker on the timeline you will see no animation. Because the keyframe animation has been stored as Fcurve in a clip. In explorer (8 key), under your Model tree, you should see “Mixer” has been created with the spinning animation in it.

To use this animation clip, make sure the blade axle is already selected, press Alt + 0 to bring up the Animation Mixer. You'll be given 2 empty tracks at the beginning. RMB click on the empty track and click Insert Source... and pick the spinning animation under the mixer.

Position the clip to fit within 1 – 300 frames by LMB dragging it. And when you click play or scrub the timeline, you can see the spinning animation.

Once the clip is placed in the animation mixer you can shortened it, make the animation clip longer, create cycles, mix it with another animation (if you have any), bridge it with another animation, etc. You can also RMB click on the clip itself to modify the Fcurve by adding keys, changing the slope, etc. But for now, leave the clip as it is, and we're done with the Windmill.
Chapter III. Valley of the Windmills - part 2

Wooden Arch
We'll start by creating a new layer from Layers drop down menu in MCP. We'll call it "Wooden_Arches_Layer". And the new layer will be set as an active layer by default.

Switch off the visibility of "WindMill_Layer" so we could work with no distraction of the windmill.

Create a Cube from Primitive -> Polygon Mesh -> Cube
Set the length to 2 and set V subdiv to 2.
Move it up by using V key so that the bottom sits on the XZ plane.
Move it 1 unit to the left (-x axis direction)
Use U key (raycast polygon selection) and select the top polygon. Hold C key, click **Local** button on MCP and LMB to rotate it about it's X local axis, rotate about 45 degree towards the origin. Press Spacebar to get into Object Selection mode when you're done.

With the object still selected, click **Edit** pull down menu on MCP -> **Duplicate/instantiate-> Duplicate Symmetry**, use the default setting and click OK.

Would would see the duplicate sits on the other side of the axis and mirrored to the the original object.
We will merge these objects so that we can do a bridge operation on them. Select both objects, on Model Toolbar, under Create section click Poly.Mesh -> Merge.

A PPG box will appear, click on **Delete (Freezes Op)** button and it closes the PPG.

Merge operation creates a new merged object. Once we merged it, we no longer need the “input” object (in this scene) so that's the reason we need to click **Delete (Freezes Op)** button.
Use U key and select the top polygons with LMB click.
RMB click on the selected polygon and click on **Bridge Polygons**.

This is what you’ll get after performing the Bridge Polygons operation...
It's not an arch yet but we'll make it by adding more subdivision along the polygons which produced form the bridge polygons operation. Select all the polygons from bridge operation (4 polys in total), RMB click on one the selected polygons and from the context menu select **Local Subdivision Refinement**.

A PPG for the Local Subdivision will appear. Set the Subdivision Level to 2 and close the PPG. Hit Spacebar to return to Object selection mode.
We will deform the bridged section by using a control object. Click on **Primitives-> Control Object -> Volume Deform** to get a control object into the scene.

Resize and positioned the control object by using V and X key so that the Control Object roughly covers the bridged section as shown below. The Control Object is currently not activated.

Once you positioned and scale the control object, hit Shift + V to activate the Control Object. Move it up, the shape of the bridged section will be affected by the Control Object and you'll get an arch shape.
That's it. We have now an arch. Let's prepare this arch into a Model which we'll use later;

- Select the Arch, click **Freeze M** button on MCP.
- Delete the Control Object. (Delete Control Object after Freezing an object, otherwise the influence on the object will be deleted as well)
- Select the arch, click on **Model** under **Create** section -> **New Model**. Name it “Wooden_Arch_Model_1”

Now we're done with the arch. Open up the Explorer (8 key) and you should be able to see 2 Models already created in the scene.

Next stop, we'll be making the terrain and we'll be placing the Windmills and the arches to our heart content. Have a break, take a cup of tea or coffee or celebrate or do anything to relax your brain.

**The Terrain**
Let's create the Terrain! We'll start with a grid and we'll paint some deformation value on it to shape hill/valley.

First of all, create a New Layer for the scene, name it “Terrain_Layer”. This will be the active layer. Toggle on the visibility of all layers.

Start with **Primitives -> Polygon Mesh -> Grid.**
Set **U length & V length** to 120 and set the **U and V subdivision** to 75.
With the grid still selected; under **Get section** click on **Property -> WeightMap**, to apply weight map on the grid. A PPG will come up, set the Base Weight to 0 and close it.
The grid is now highlighted blue. **Do not Hit Spacebar yet!!!!!**
Next, switch to Animate Toolbar (2 key), click on **Deform -> Push** (while the grid is till highlighted blue)
A PPG will appear, set the Amplitude value to 20.
Next to Amplitude value (on the right), there's an Connect Icon. If the Icon is Red that means it is already connected to the grid's Weight Map.

If it's not connected (you accidentally hit spacebar earlier to get to object selection mode), we'll connect it manually;
- Click on the connection icon
- Open up explorer (8 key), browse for `Weight_Map` node under `Clusters->WeightMapCls` node, and click it.
- The amplitude is now connected to the grid's weight map, set the Amplitude value to 20.

Hit **Ctrl + W** to open up the brush properties, lock the PPG (by clicking lock icon on the top-right of the PPG). Maximise the perspective viewport, select the grid, hold down **W** key to enable the Paint Tool.

Use LMB to add deformation and use RMB to remove it. While the brush PPG is open you can adjust the opacity of the brush, which effects the deformation. Use MMB dragging to adjust the size of the brush while painting deformation on the grid.

Use the sketch provided to shape the valley, or design the valley of your own.
When you're done, freeze the grid with **Freeze M** button on the MCP. We're done with terrain.
Simple Duplicating/Cloning/Instancing
A short note on these operations....

<table>
<thead>
<tr>
<th>Duplicate</th>
<th>-&gt; Ctrl + D</th>
<th>Duplicate without Options</th>
<th>-&gt; Ctrl + Alt + D</th>
</tr>
</thead>
<tbody>
<tr>
<td>Clone</td>
<td>-&gt; access from menu</td>
<td>Clone without Options</td>
<td>- &gt; access from menu</td>
</tr>
<tr>
<td>Instantiate</td>
<td>-&gt; Ctrl + I</td>
<td>Instantiate without Options</td>
<td>- &gt; Ctrl + Alt + I</td>
</tr>
</tbody>
</table>

If you need to duplicate an object, firstly you need to select an object and press Ctrl + D (or access the menu).
Once you performed the Duplicate/Clone/Instancing, the new object will be highlighted. The first object will be put on the position of the original object.

If you performed another Duplicate/Clone/Instance on the resulting object after being transformed (SRT) the result will inherit the transformation as well.

Have a look at these following cases;

1. ) You have a cube at (0, 0, 0). Ctrl + D will create another cube at (0, 0, 0). The resulting object will be highlighted. Then you move the new cube to (0, 0, 10). If you press Ctrl + D with the new cube still highlighted, the new cube will be placed at (0, 0, 20), if you press Ctrl + D again, the new cube will be placed at (0, 0, 30).

2.) You have a cube at (0, 0, 0). Ctrl + D will create a new cube at (0, 0, 0). Then you move the new cube to (10, 0, 0).
   ○ If you press Ctrl + D while the new cube still highlighted, the resulting cube will be at (20, 0, 0).
   ○ But, if you press Ctrl + Alt + D, the resulting cube will be at (10, 0, 0), which is the position of the source object, not the original cube.

3.) You have a cube at (0, 0, 0). Ctrl + D will place the new object on the original cube's position. You move it to (0, 0, 10). Deselect the new cube and select the original cube. Press Ctrl + D again, it will place another new cube at (0, 0, 0)

4.) You have a cube at (0, 0, 0). Ctrl + D will place the new cube at the same position of the original cube. You move it to (0, 0, 10). Then you decided to add 5 more cubes. With the new cube still highlighted hit Ctrl + D 5 times. (or use duplicate multiple option from the original ones)

If you want to use Ctrl + D/I without having your new objects going everywhere on the screen, make sure that you perform the Duplicate/Clone/Instancing operations on the original Object not the resulting object.

If you want to perform Duplicate/Clone/Instancing operation on a resulting object from previous operation, without inheriting the transformations; use Ctrl + Alt + D/I so that the new object will not inherit the transformations performed on source object.

This works the same way with Cloning operation.
Placing The Windmills and the Arches
Let's start with the windmill first. Open up Layer Control with 6 key. Make the “WindMill_Layer” as the active layer by RMB click on box to the left of layer name and click “Set as Current layer”. This way, the duplicates of the windmill will be in the same layer as the original object.

Let's do the instancing. Open up Explorer (8 key), select the Model node of the windmill. Click Edit pull down menu (on MCP) -> Duplicate/Instantiate -> Instantiate Single.

The new Model will be created on the top of the original Model. Use V key to move it away. Repeat the Instancing step from the original Model to get to other windmill.

You should now have 3 windmills in the scene. Use V key and C key to position the windmills in the valley.

... ... ... you should be a little bit more familiar with the keys and the menus in XSI. So, here's the next step. Repeat the procedure above for the arches! :)

© Interactive Systems and Virtual Reality Research Group – Macquarie University, 2006
You're doing great. Next stop is camera animation. Have a break and proceed when you're ready.
**Animating Camera on a Path**

First of all create a new layer for this path, name it “Camera_Anim_Layer”. You should know how to create a new layer by now.

We'll draw the camera path from the top viewport, so maximise to your top viewport now to make this work easier.

On Model Toolbar, under *Create* section -> *Curve* -> *Draw Cubic by Cvs.*

Place several points to go through the arches and a little bit closer to the nearest windmill.

Hit Enter key when you're done, name it “Camera_Path”

Hit ESC key to quit from the Draw Tool.

Mine look like this illustration below...
Now, switch to your perspective viewport. We'll do further arrangement from here.

Move the curve up above the ground, and use M key (with LMB, MMB or RMB) to move points of the curve if you wish to modify the shape of your curve.

Make sure the curve is not too close to the ground and not too close to the top of the arch.

After moving several points of the curve, mine looks like...

With the path is set, let's create a new camera. Model Toolbar -> Under Get section -> **Camera** -> **perspective**. A PPG for the new camera will appear. Name it something catchy and set the Horizontal *Field of View* to 65. Close the PPG when you're finished.

With the Camera still selected (if it's not selected, use Spacebar and RMB to select the whole camera tree), activate the Animate Toolbar.
Under Create section -> Path -> Set Path, a PPG will pop up confirming that the animation will be from frame 1 – 300, click OK to close it. Now, we need to make selection which curve will be used for path animation. Pick the curve we created earlier.

After you picked the curve a PPG of path constrains will appear. In this illustration below, the Path% is at 49 not 0, because when this screen was captured my marker is not at frame 1 on the timeline.

Click on Tangency Tab, activate the Tangency option and set the align axis to -Z. The New camera should now oriented in the right direction. Now you can close the PPG.
Set one of the viewport to look inside your camera, by clicking the Viewport name -> Cameras -> Your Camera.

Maximise your camera's viewport and hit play! While you're viewing inside an animated camera, **DO NOT** perform any camera movements (Dolly/Pan/Zoom), your camera animation would be a mess.

Congratulations! You've just finished “Valley of the Windmills” Tutorial.
Chapter IV. I want more...

At the end of “Valley of the Windmills” tutorial, you have learned;

- XSI user interface (where to find things)
- Working with hot keys
- Working in SI|3D selection mode
- Basic polygon modeling
- Keyframe animation to Fcurve
- Working with Animation Mixer
- Working in layers
- Organising object in hierarchy
- Deforming polygon by weight map and push operations
- Camera - path animation

(well... that's a lot!)

Modeling, Animation, Texturing and Rendering are different subjects. Cinematography is also another subject under Animation. What you've done is just a small bit of Modeling and Animation.

We did not cover Texturing and Rendering because the aim of this Tutorial is to give you an introduction in XSI. I believe that I have accomplished it here. Besides, who would like to do a 80 pages tutorial? They will be in another tutorial.

Practice makes perfect. Learn from others and share your knowledge.
Chapter V. Recommended Reading

For those who want to learn more about digital animation, I've provided a small list of resources which would help learning XSI.

**XSI Books**
XSI Illuminated: Foundation v4.x, Mesmer Press.
XSI Illuminated: Character 2.0.x, Mesmer Press.
Experience XSI4: The Official guide to Character Creation.

**XSI Tutorials**
http://www.edharriss.com/index.htm
http://www.xsibase.com/
www.3dlinks.com

**Commercial Tutorial DVDs**
http://www.thegnomonworkshop.com
http://www.softimage.com
http://www.highend3d.com

**Other documentations**
Softimage|XSI help file :)

**General Modeling/Lighting/Rendering/Animation**
There are lots of places on the web where you could find tutorials for others 3D software packages.
www.highend3d.com
www.3dlinks.com
and many many more...

Books by Mesmer are easy to follow for beginners. It's highly recommended.

The guys at Gnomon workshop are professionals from leading movies and special effects industries. They have lots of DVDs tutorials (making sketches, paintings, modeling, texturing, rigging, animating, rendering, special effects and compositing) and you can see how professionals do their work for a big production effectively. Gnomon is Highly recommended as well.
Chapter V. Final Thoughts

Knowing how to use a particular 3D software effectively would enable you to learn other 3D softwares easily. Every 3D software will have different terminology and workflow, but if you know what you want to do or see and how to accomplish your task, these wouldn't be a problem.

For an example; in XSI, I would press '6' to open up Shader Tree to create or edit my object's shader, in MAYA, this equivalent to 'H', and will bring up Hypershade. Hypershade and Render Tree have different look and options but they both allow to create or edit shader.

Read book on techniques of modeling for other 3D software, learn the technique. Some people would buy only XSI only books or MAYA only books. You may not be able to trace the exact way they do it in the books but you can always grab the technique and apply it.

Plan your works, don't waste your valuable time by working arbitrarily. Always start with a SKETCH first.
Iwan would like to thank;

*My Saviour and My Redeemer, Lord Jesus Christ, Thank you for letting me to share my XSI knowledge to others.*

*Dr. Manolya Kavakli and ISVR team, thanks for being patient with me and thanks for letting me share my knowledge, and thanks to my family for the support.*

and these following people for guidance and inspirations in learning XSI through their publications; *Anthony Rossano & Shinsaku Arima (for XSI Illuminated Foundation and Character, the best guide to XSI I've ever read), Aaron Sims, Michael Isner, Ed Harris.com, and everyone at XSI Base.*